<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	            <title>Sleeping With Sirens are back with new single &#039;Crosses&#039;, and new album &#039;Complete Collapse&#039; | Upset</title>
        
	<link href="/css/style.css" rel="stylesheet">
	<link href="/css/columns.css" rel="stylesheet">
	<link href="/css/magnific-popup.css" rel="stylesheet" >
	<script src="/js/dork.js"></script>
	<link href="/css/mobhide.css" rel="stylesheet">
	
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
	
			<meta name="description" content="The full-length will arrive in October.">
	<meta property="og:description" content="The full-length will arrive in October." />
	<meta property="og:image" content="https://www.upsetmagazine.com/images/article/Artist-Images/S/Sleeping With Sirens/SLEEPING-WITH-SIRENS-BY-ASHLEY-OSBORN-jul22.jpg" />
	<meta property="og:site_name" content="Upset" />
	<meta property="og:title" content="Sleeping With Sirens are back with new single &#039;Crosses&#039;, and new album &#039;Complete Collapse&#039;" />
	<meta property="og:type" content="website" />
	<meta property="og:url" content="https://www.upsetmagazine.com/news/sleeping-with-sirens-album-complete-collapse" />
	
	<meta name="twitter:card" content="summary" /> 
	<meta name="twitter:url" content="https://www.upsetmagazine.com/news/sleeping-with-sirens-album-complete-collapse" /> 
	<meta name="twitter:title" content="Sleeping With Sirens are back with new single &#039;Crosses&#039;, and new album &#039;Complete Collapse&#039;" /> 
	<meta name="twitter:description" content="The full-length will arrive in October." /> 
	<meta name="twitter:image:src" content="https://www.upsetmagazine.com/images/article/Artist-Images/S/Sleeping With Sirens/SLEEPING-WITH-SIRENS-BY-ASHLEY-OSBORN-jul22.jpg" /> 	
	<link rel="canonical" href="https://www.upsetmagazine.com/news/sleeping-with-sirens-album-complete-collapse" />
	
	<meta name="twitter:site" content="upsetmagazine" />
	<meta property="twitter:account_id" content="3093013045" />
	

	<link rel="shortcut icon" href="/images/upsetlogo_2018_favd.png" />
	<link rel="alternate" type="application/rss+xml" title="Upset" href="/feed.rss" />
  <script>
                window.addEventListener("load", function(){
                window.cookieconsent.initialise({
                  "palette": {
                    "popup": {
                      "background": "#000000",
                      "text": "#ffffff"
                    },
                    "button": {
                      "background":  "block" === "wire" ? "transparent" :  "#f1d600",
                      "text": "block" === "wire" ? "#f1d600" : "#000000",
                      "border":  "block" === "wire" ? "#f1d600" : undefined
                    }
                  },
                  "position": "bottom" === "toppush" ? "top" : "bottom",
                  "static": "bottom" === "toppush",
                  "theme": "block",
                  "content": {
                    "message": "This website uses cookies to ensure you get the best experience on our website.&nbsp;",
                    "dismiss": "Got it!",
                    "link": "Learn More",
                    "href": "http://cookiesandyou.com/"
                  }
                })});
              </script><link href="https://www.upsetmagazine.com/cpresources/fc05e024/css/cookieconsent.min.css?v=1617964091" rel="stylesheet"></head>
  <body>
	  
	  <header>
		  <div class="leaderboard">
		  	<div class="ad">
				<!-- 970 x 250 [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc196924 = window.plc196924 || 0;
document.write('<'+'div id="placement_196924_'+plc196924+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(167440, 196924, [970,250], 'placement_196924_'+opt.place, opt); }, opt: { place: plc196924++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script>
			</div>
		  </div>
		  
		  <div id="header" style="background-color:#111; border-bottom: 0px dashed #fff; border-top: 1px dashed #fff; color:#fff;"><div class="topwrapper">
		  <div style="float:left; width:400px; display:inline-block;">
		  <form action="https://www.upsetmagazine.com/search/results">    <input autocomplete="off" type="search" name="q" class="searchbox" style="background-color:#111; color:#fff; border-bottom:#fff 1px solid; -webkit-appearance: none;">
    <input type="submit" value="Search" class="searchbutton"  style="background-color:#111; color:#fff;">
</form></div> 

<div class="subtext" style="font-weight:400; text-transform:uppercase; letter-spacing:2px; font-size:14px;">Disrupt the noise</div>
<div style="clear:both"></div>		  
		 </div>
		 <div id="moblogo" style="text-align:center;">
		  	<a href="/"><img src="/images/upsetlogo_2018_d.png" style="max-height:90px;padding-top:25px;"></a>
		  </div>
		 <div class="navwrapper"><a href="#" onclick="toggle_visibility('navbar');"><img src="/images/menuicon.png" style="max-width:32px; float:right;"></a></div></div>
		  
		  <div id="logo"  style="text-align:center;">
		  	<a href="/"><img src="/images/upsetlogo_2018_d.png" style="max-height:115px;padding-top:18px;"></a>
		  </div>
		  
		  		  <div id="subheader" style="background-color:#111; color:#fff; border-bottom:1px dashed #fff;">
					  <div class="wrapper">
							<div id="subheader_left" style="padding-bottom:16px;">
							<div style="border:5px solid #fff; color:#fff; padding:15px; height:75px; width:250px;"><span style="font-size:20px"><a href="/magazine/subscribe" style="color:#fff;">Subscribe to Upset</a></span><br>Get Upset delivered direct to your door anywhere on the planet, every month. <a href="/magazine/subscribe" style="color:#fff;">Get more info here.</a></div>

							</div>
							
							
							         <div id="subheader_right">
								<div class="subheader_right_copy">
									<div class="subheader_tagdiv"><span class="subheader_tag" style="border-bottom: 5px solid #fff;">In the mag...</span></div>
									<span class="subheader_head">Featuring <strong>Nova Twins, Alexisonfire, My Chemical Romance, Joyce Manor</strong> and more.</span><br/>
									<a href="https://www.upsetmagazine.com/magazine/july-2022" style="color:#fff; background-color: transparent;">Order a copy</a>
								</div>
								<a href="https://www.upsetmagazine.com/magazine/july-2022" alt="This month's magazine"><img src="https://www.upsetmagazine.com/images/article/Magazine-Images/July 2022/Upset-July-2022-top.jpg" style="width:150px; max-width: 150px; float:right; padding-left:20px;" alt="July 2022"></a>
							</div>
            							
							
							
					  		
					  </div>
</div>
		  <div class=" mobhide navpad" id="navbar" style="text-align:center;background-color:#111; color:#fff;"><div style="text-align:center; letter-spacing: 3px;padding:10px 10px 15px 10px;font-weight:400; font-size:16px; background-color:#111; color:#fff;"><a href="/news/" style="color:#fff; margin-right:15px; text-decoration:none;">NEWS</a> <a href="/features/" style="color:#fff; margin-right:15px; text-decoration:none;">FEATURES</a> <a href="/photos/" style="color:#fff; margin-right:15px; text-decoration:none;">PHOTOS</a> <a href="/reviews/" style="color:#fff; margin-right:15px; text-decoration:none; text-decoration:none;border-right:1px solid #fff;padding-right:15px;">REVIEWS</a> <a href="/magazine/" style="color:#fff; margin-right:15px; text-decoration:none;border-right:1px solid #fff;padding-right:15px;">MAGAZINE</a> <a href="/buy/" style="color:#fff; margin-right:0px; text-decoration:none;">BUY</a></div>
		  </div>
		<div style="width:100%; margin-top:-5px;"><img src="/images/cut.png" style="width:100%"></div>	
  
	  </header>	
<div class="wrapper">
	<div class="tagdiv"><span class="tag" style="border-bottom: 10px solid #ff0000;">Coming soon</span></div>
		<h1>Sleeping With Sirens are back with new single &#039;Crosses&#039;, and new album &#039;Complete Collapse&#039;</h1>
		<div class="standfirst">The full-length will arrive in October.</div>
		

		
		<div style="border-top: 1px dashed #111;padding-top:5px; margin-top:10px;border-bottom: 1px dashed #111;padding-bottom:5px;"><span style="padding-right:10px"><strong>Published:</strong> 12:11 pm, June 22, 2022</span>		
				
		</div>
		
		<div class="mainimage" style="position: relative; top: 0; left: 0;"><img src="https://www.upsetmagazine.com/images/article/Artist-Images/S/Sleeping With Sirens/_crop1500x1000/SLEEPING-WITH-SIRENS-BY-ASHLEY-OSBORN-jul22.jpg" href="https://www.upsetmagazine.com/images/article/Artist-Images/S/Sleeping With Sirens/_crop1500x1000/SLEEPING-WITH-SIRENS-BY-ASHLEY-OSBORN-jul22.jpg" alt="Sleeping With Sirens are back with new single &#039;Crosses&#039;, and new album &#039;Complete Collapse&#039;" class="gallery-item" style="position: relative; top: 0; left: 0; z-index:1; cursor: pointer;"><img style="width:18px; position: absolute; bottom:20px; right:10px; z-index:3;" src="/dork/images/zoom.png"></div>

<div class="maincopy">
		
    <div class="mpu mobhide">
<!-- MPU [iframenojs] -->
<iframe src="https://servedbyadbutler.com/adserve/;ID=167440;size=300x250;setID=251619;type=iframe;click=CLICK_MACRO_PLACEHOLDER" width="300" height="250" marginwidth="0" marginheight="0" hspace="0" vspace="0" frameborder="0" scrolling="no">
</iframe>
</div><p><strong>Sleeping With Sirens</strong> have announced their new album, <strong>'Complete Collapse'.</strong></p>
<p>The full-length will arrive on 14th October via Sumerian Records, preceded by new single<strong> 'Crosses (feat. Spencer Chamberlain, Underoath)'.</strong></p>
<p>Frontman <strong>Kellin Quinn</strong> comments: "I think "Crosses" is a great opening single for our new album! The song to me is about not putting yourself above anyone. I think we’re all just trying our best and we can lift each other up! In a world where everyone pretends to be perfect, I think this song is letting everyone know that we all struggle and we can all rise above it!</p>
<p>"Spencer Chamberlain really elevated this song! Underoath is a huge influence for me when it comes to making music. It was an honour working with somebody I really look up to!</p>
<p>"The video for "Crosses" was something I really wanted to feel light-hearted to counteract the heavy subject matter. Not everything has to be so serious all the time! The video was a blast to shoot, Brian Cox took my concept and really made an amazing video!</p>
<p>"If you love with ears to see and eyes to hear, let’s cheers, and madness! You’re going to LOVE this new album!"</p>
<p>The album's tracklisting reads:<br><br>Tyrants<br>Complete Collapse<br>Crosses (feat. Spencer Chamberlain of Underoath)<br>Family Tree<br>Let You Down (feat. Charlotte Sands)<br>Be Happy (feat. Royal & The Serpent)<br>Us (feat. Dorothy)<br>Ctrl + Alt + Del<br>Bloody Knuckles<br>Mr. Nice Guy<br>Apathetic<br>Grave</p>
 </div>	    
<div class="mainimage"><style>.embed-container { position: relative; padding-bottom: 56.25%; height: 0; overflow: hidden; max-width: 100%; } .embed-container iframe, .embed-container object, .embed-container embed { position: absolute; top: 0; left: 0; width: 100%; height: 100%; }</style><div class='embed-container'><iframe src='https://www.youtube.com/embed/-BfkVzfBr7c' frameborder='0' allowfullscreen></iframe></div></div>

	
	<div style="padding-bottom:30px;"><div class="ad">
	<!-- 970 x 250 [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc196924 = window.plc196924 || 0;
document.write('<'+'div id="placement_196924_'+plc196924+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(167440, 196924, [970,250], 'placement_196924_'+opt.place, opt); }, opt: { place: plc196924++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script>

			</div></div>  
<div class="sectionindex">
	<div class="container-fluid mobhide">
         <div class="row tih_yellow" style="background-color:#fff; border:10px solid #111;">
         	<div class="col-md-2 tih_row">
         		<img src="/images/needtoknow.png" style="width:95%">
         		<div class="tih_subheader">Everything going on in rock, right now.</div>
         	</div>
            			<div class="col-md-2">
               <div class="tih_rowpadding">
                  <div class="recimage">
                  	                  	<img src="https://www.upsetmagazine.com/images/article/Artist-Images/C/Crawlers/_crop600x400/crawlers-apr22.jpg" alt="Crawlers have shared a new video for ‘Fuck Me (I Didn’t Know How To Say)’">
                  	                </div>
                <div>
                  <div class="rectagdiv">
                    					<span class="rectag tih_tag">Watch</span>
                                    	  </div>
                  <h3 class="tih_h3"><a href="https://www.upsetmagazine.com/news/crawlers-video-fuck-me-i-didnt-know-how-to-say" style="background-color:transparent;">Crawlers have shared a new video for ‘Fuck Me (I Didn’t Know How To Say)’ 
<br/><strong>More &raquo;</strong></a></h3>
				  				                  </div>
            </div>
        	</div>
        			<div class="col-md-2">
               <div class="tih_rowpadding">
                  <div class="recimage">
                  	                  	<img src="https://www.upsetmagazine.com/images/article/Artist-Images/A/Alexisonfire/_crop600x400/Alexisonfire-mar22.jpg" alt="Alexisonfire: &quot;This is the best era of Alexisonfire&quot;">
                  	                </div>
                <div>
                  <div class="rectagdiv">
                    					<span class="rectag tih_tag">Feature</span>
                                    	  </div>
                  <h3 class="tih_h3"><a href="https://www.upsetmagazine.com/features/alexisonfire-interview-jul22" style="background-color:transparent;">Alexisonfire: &quot;This is the best era of Alexisonfire&quot; 
<br/><strong>More &raquo;</strong></a></h3>
				  				                  </div>
            </div>
        	</div>
        			<div class="col-md-2">
               <div class="tih_rowpadding">
                  <div class="recimage">
                  	                  	<img src="https://www.upsetmagazine.com/images/article/Artist-Images/B/Baby Strange/_crop600x400/baby-strange-apr22.jpg" alt="Baby Strange have shared a video for &#039;Only Feel It When I’m With You (Feat. The Jezabels’ Hayley Mary)&#039;">
                  	                </div>
                <div>
                  <div class="rectagdiv">
                    					<span class="rectag tih_tag">Watch</span>
                                    	  </div>
                  <h3 class="tih_h3"><a href="https://www.upsetmagazine.com/news/baby-strange-video-only-feel-it-when-im-with-you" style="background-color:transparent;">Baby Strange have shared a video for &#039;Only Feel It When I’m With You (Feat. The Jezabels’ Hayley Mary)&#039; 
<br/><strong>More &raquo;</strong></a></h3>
				  				                  </div>
            </div>
        	</div>
        			<div class="col-md-2">
               <div class="tih_rowpadding">
                  <div class="recimage">
                  	                  	<img src="https://www.upsetmagazine.com/images/article/Artist-Images/P/Petrol-Girls/_crop600x400/PetrolGirls_Day2-60-jul22.jpg" alt="Petrol Girls: &quot;I can be lots of different things&quot;">
                  	                </div>
                <div>
                  <div class="rectagdiv">
                    					<span class="rectag tih_tag">Feature</span>
                                    	  </div>
                  <h3 class="tih_h3"><a href="https://www.upsetmagazine.com/features/petrol-girls-interview-jul22" style="background-color:transparent;">Petrol Girls: &quot;I can be lots of different things&quot; 
<br/><strong>More &raquo;</strong></a></h3>
				  				                  </div>
            </div>
        	</div>
        			<div class="col-md-2">
               <div class="tih_rowpadding">
                  <div class="recimage">
                  	                  	<img src="https://www.upsetmagazine.com/images/article/Artist-Images/B/Biffy-Clyro/_crop600x400/biffy-clyro-mar20.jpg" alt="Biffy Clyro and Architects have announced a November UK tour">
                  	                </div>
                <div>
                  <div class="rectagdiv">
                    					<span class="rectag tih_tag">On the road</span>
                                    	  </div>
                  <h3 class="tih_h3"><a href="https://www.upsetmagazine.com/news/biffy-clyro-architects-uk-tour" style="background-color:transparent;">Biffy Clyro and Architects have announced a November UK tour 
<br/><strong>More &raquo;</strong></a></h3>
				  				                  </div>
            </div>
        	</div>
              </div>
    </div>
</div>
  
 </div>
	  
  <div class="wrapper"><div style="text-align:center; border-top:10px solid #111;margin-top:50px; padding-bottom:50px;">
<div style="text-align:center; letter-spacing: 5px;padding:10px; border-bottom:1px solid #111; font-weight:700; margin-bottom:30px; font-size:0.8em;"><a href="/contact/" style="color:#111; margin-right:15px; text-decoration:none;">CONTACT</a> <a href="/privacy/" style="color:#111; margin-right:15px; text-decoration:none;">PRIVACY</a> <a href="/advertise/" style="color:#111; margin-right:0px; text-decoration:none;">ADVERTISE</a></div><a href="http://www.welcometothebunker.com"><img src="/images/bunkerlogo.png" style="max-width:150px;margin-bottom:10px;"></a><br>  © 2018 The Bunker Publishing</div></div>
<script src="/js/jquery.magnific-popup.js"></script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-60857358-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-60857358-1');
</script>

<style>
.cc-revoke, .cc-window {
font-family: Calibre, Helvetica,Calibri,Arial,sans-serif; }
</style>
  <script src="https://www.upsetmagazine.com/cpresources/fc05e024/js/cookieconsent.min.js?v=1617964091"></script></body>
</html>